$re = '/^([\w.-]+)=([A-Za-z0-9.-]+):(\d+)$/m';
$str = 'minecraft.local=minecraft-java.ix-minecraft-java.svc.cluster.local:25565';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);