package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\x41-\x5A][\x61-\x7A]{2}\x20[\x30-\x39]+\x2C\x20[\x30-\x39]{4}`)
var str = `Feb 27, 2019
Mar 31, 2019
Mar 31, 2019
Mar 31, 201900
00Mar 31, 2019
March 31, 2019
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}