import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\x41-\\x5A][\\x61-\\x7A]{2}\\x20[\\x30-\\x39]+\\x2C\\x20[\\x30-\\x39]{4}";
final String string = "Feb 27, 2019\n"
+ "Mar 31, 2019\n"
+ "Mar 31, 2019\n"
+ "Mar 31, 201900\n"
+ "00Mar 31, 2019\n"
+ "March 31, 2019\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}