$re = '/[\x41-\x5A][\x61-\x7A]{2}\x20[\x30-\x39]+\x2C\x20[\x30-\x39]{4}/m';
$str = 'Feb 27, 2019
Mar 31, 2019
Mar 31, 2019
Mar 31, 201900
00Mar 31, 2019
March 31, 2019
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);