using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(somebody)(?!.*(typed|nice)).*(words)";
string input = @"Somebody has written down some words.
Somebody has written down nice words.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}