$re = '/(somebody)(?!.*(typed|nice)).*(words)/i';
$str = 'Somebody has written down some words.
Somebody has written down nice words.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);