re = /(somebody)(?!.*(typed|nice)).*(words)/i
str = 'Somebody has written down some words.
Somebody has written down nice words.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end