const regex = /\h*(.*?\[[^][]*])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h*(.*?\\[[^][]*])', 'gm')
const str = `i want to show you my youtube channel : [youtube id=12341234] and my instagram account : [instagram id=myingaccount213]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}