#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bDELIVER TO:\r?\n[ \t]*(\S+).*(?:\r?\n.*){2}.*[ \t](\S+)"
Local $sString = "RECOVER FROM:" & @CRLF & _
"" & @CRLF & _
"Company 1" & @CRLF & _
"" & @CRLF & _
"Bla: Bla" & @CRLF & _
"" & @CRLF & _
"Bla: Bla" & @CRLF & _
"" & @CRLF & _
"Bla: Bla" & @CRLF & _
"" & @CRLF & _
"Bla: Bla" & @CRLF & _
"" & @CRLF & _
"Bla: Bla" & @CRLF & _
"" & @CRLF & _
"Bla" & @CRLF & _
"" & @CRLF & _
"DELIVER TO:" & @CRLF & _
"" & @CRLF & _
"Sypris Solutions, Inc." & @CRLF & _
"" & @CRLF & _
"Street 123" & @CRLF & _
"" & @CRLF & _
"City ZIP US" & @CRLF & _
"" & @CRLF & _
"Bla: Bla" & @CRLF & _
"" & @CRLF & _
"Bla: Bla" & @CRLF & _
"" & @CRLF & _
"Bla: Bla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")