re = /\bDELIVER TO:\r?\n[ \t]*(\S+).*(?:\r?\n.*){2}.*[ \t](\S+)/
str = 'RECOVER FROM:
Company 1
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla
DELIVER TO:
Sypris Solutions, Inc.
Street 123
City ZIP US
Bla: Bla
Bla: Bla
Bla: Bla'
# Print the match result
str.match(re) do |match|
puts match.to_s
end