import Foundation
let pattern = #"\bDELIVER TO:\r?\n[ \t]*(\S+).*(?:\r?\n.*){2}.*[ \t](\S+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
RECOVER FROM:
Company 1
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla: Bla
Bla
DELIVER TO:
Sypris Solutions, Inc.
Street 123
City ZIP US
Bla: Bla
Bla: Bla
Bla: Bla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}