using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<JUNK>.*?)(\([^)]*\)\s)?name:(?P<name>\d+)\.$";
string input = @"ID pqr name:123.
ID pqr (a) () name:123.
ID pqr (a) (b) () name:123.
ID pqr (a) (b) () name:123.
ID pqr (a) (b) (XX) name:123.
ID pqr (a) (b) (X) name:123.
ID pqr (aa) (b) (X) name:123.
ID pqr (a) (bb) (X) name:123.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}