re = /^(?P<JUNK>.*?)(\([^)]*\)\s)?name:(?P<name>\d+)\.$/m
str = 'ID pqr name:123.
ID pqr (a) () name:123.
ID pqr (a) (b) () name:123.
ID pqr (a) (b) () name:123.
ID pqr (a) (b) (XX) name:123.
ID pqr (a) (b) (X) name:123.
ID pqr (aa) (b) (X) name:123.
ID pqr (a) (bb) (X) name:123.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end