package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<JUNK>.*?)(\([^)]*\)\s)?name:(?P<name>\d+)\.$`)
var str = `ID pqr name:123.
ID pqr (a) () name:123.
ID pqr (a) (b) () name:123.
ID pqr (a) (b) () name:123.
ID pqr (a) (b) (XX) name:123.
ID pqr (a) (b) (X) name:123.
ID pqr (aa) (b) (X) name:123.
ID pqr (a) (bb) (X) name:123.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}