#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z][\w+-]+(?:\.\w+)?)@([\w-]+(?:\.[a-z]{2,10})+)$"
Local $sString = "a@co.kk.pp" & @CRLF & _
"aa.@co.kk.pp" & @CRLF & _
"aa..@co.kk.pp" & @CRLF & _
"a.a@co.kk.pp" & @CRLF & _
"" & @CRLF & _
"aa@co.kk.pp" & @CRLF & _
"aaa@co.kk.pp" & @CRLF & _
"aa.s@co.kk.pp" & @CRLF & _
"aa.ss@co.kk.pp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")