// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z][\w+-]+(?:\.\w+)?)@([\w-]+(?:\.[a-z]{2,10})+)$").unwrap();
let string = "a@co.kk.pp
aa.@co.kk.pp
aa..@co.kk.pp
a.a@co.kk.pp
aa@co.kk.pp
aaa@co.kk.pp
aa.s@co.kk.pp
aa.ss@co.kk.pp";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}