const regex = /^([a-zA-Z][\w+-]+(?:\.\w+)?)@([\w-]+(?:\.[a-z]{2,10})+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z][\\w+-]+(?:\\.\\w+)?)@([\\w-]+(?:\\.[a-z]{2,10})+)$', 'gm')
const str = `a@co.kk.pp
aa.@co.kk.pp
aa..@co.kk.pp
a.a@co.kk.pp
aa@co.kk.pp
aaa@co.kk.pp
aa.s@co.kk.pp
aa.ss@co.kk.pp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}