using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"G0\d+\sZ.*";
string input = @"G01 Z-1.000000 F200.0(Penetrate)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}