package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)G0\d+\sZ.*`)
var str = `G01 Z-1.000000 F200.0(Penetrate)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}