$re = '/G0\d+\sZ.*/m';
$str = 'G01 Z-1.000000 F200.0(Penetrate)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);