#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[[:alpha:]_]\w*$"
Local $sString = "setlibpath" & @CRLF & _
"_setlibpath" & @CRLF & _
"__setlibpath" & @CRLF & _
"12setlibpath" & @CRLF & _
"hello123" & @CRLF & _
"helloworld" & @CRLF & _
"worldhello" & @CRLF & _
"123hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")