$re = '/^[[:alpha:]_]\w*$/m';
$str = 'setlibpath
_setlibpath
__setlibpath
12setlibpath
hello123
helloworld
worldhello
123hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);