import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[[:alpha:]_]\\w*$";
final String string = "setlibpath\n"
+ "_setlibpath\n"
+ "__setlibpath\n"
+ "12setlibpath\n"
+ "hello123\n"
+ "helloworld\n"
+ "worldhello\n"
+ "123hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}