package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[?&])(\w+)(?:=)(\w+)`)
var str = `url="https://www.youtube.com/watch?zip=12345&city=Miami&country=US"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}