$re = '/(?:[?&])(\w+)(?:=)(\w+)/m';
$str = 'url="https://www.youtube.com/watch?zip=12345&city=Miami&country=US"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);