re = /(?:[?&])(\w+)(?:=)(\w+)/m
str = 'url="https://www.youtube.com/watch?zip=12345&city=Miami&country=US"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end