$re = '/(?x)([A-Z]\.)+|\$?\d+(\.\d+)?%?|\w+([-\']\w+)*|[+/\-@&*]/smx';
$str = '32188
2598473
26 letters from A to Z
3.14 is pi.
My weight is about 68 kg, +/- 10 grams.
Good muffins cost $3.88 in New York
U.S.A.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);