import re
regex = re.compile(r"""
(?x)([A-Z]\.)+|\$?\d+(\.\d+)?%?|\w+([-']\w+)*|[+/\-@&*]
""", flags=re.DOTALL | re.MULTILINE | re.VERBOSE)
test_str = ("32188\n"
"2598473\n"
"26 letters from A to Z\n"
"3.14 is pi.\n"
"My weight is about 68 kg, +/- 10 grams.\n"
"Good muffins cost $3.88 in New York\n"
"U.S.A.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")