// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?smx)(?x)([A-Z]\.)+|\$?\d+(\.\d+)?%?|\w+([-']\w+)*|[+/\-@&*]").unwrap();
let string = "32188
2598473
26 letters from A to Z
3.14 is pi.
My weight is about 68 kg, +/- 10 grams.
Good muffins cost $3.88 in New York
U.S.A.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}