const regex = /\b[bB][yY]\b(?!.*\b[bB][yY]\b.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[bB][yY]\\b(?!.*\\b[bB][yY]\\b.*)', 'gm')
const str = `Go by the office and pickup milk by the safeway BY tomorrow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}