$re = '/\b[bB][yY]\b(?!.*\b[bB][yY]\b.*)/m';
$str = 'Go by the office and pickup milk by the safeway BY tomorrow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);