re = /\b[bB][yY]\b(?!.*\b[bB][yY]\b.*)/m
str = 'Go by the office and pickup milk by the safeway BY tomorrow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end