$re = '/[^a-zA-Z0-9_\s]/';
$str = 'assccÑasas
StÀck Overflow
stack overflow;
stack overflow
i can still check for character like ì or Æ ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);