// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^a-zA-Z0-9_\s]").unwrap();
let string = "assccÑasas
StÀck Overflow
stack overflow;
stack overflow
i can still check for character like ì or Æ ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}