#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\d{9}$)\d*(\d\d)\1{3}\d*$"
Local $sString = "561616161" & @CRLF & _
"121212123" & @CRLF & _
"411111111" & @CRLF & _
"111111114" & @CRLF & _
"" & @CRLF & _
"111111111" & @CRLF & _
"299887766" & @CRLF & _
"887756564" & @CRLF & _
"123412345" & @CRLF & _
"123123123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")