import re
regex = re.compile(r"^(?=\d{9}$)\d*(\d\d)\1{3}\d*$", flags=re.MULTILINE)
test_str = ("561616161\n"
"121212123\n"
"411111111\n"
"111111114\n\n"
"111111111\n"
"299887766\n"
"887756564\n"
"123412345\n"
"123123123\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")