const regex = /^(.*?)\s*(^|\W)(1st|2d)($|\W)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\s*(^|\\W)(1st|2d)($|\\W)', 'gm')
const str = `covid19 1st case
covid19 2d case
covid19 1std 1st case`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}