$re = '/^(.*?)\s*(^|\W)(1st|2d)($|\W)/m';
$str = 'covid19 1st case
covid19 2d case
covid19 1std 1st case';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);