re = /^(.*?)\s*(^|\W)(1st|2d)($|\W)/m
str = 'covid19 1st case
covid19 2d case
covid19 1std 1st case'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end