#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?:\G(?!\A)|\QLast Transaction(s)\E\s+)" & @CRLF & _
"\s*<br>\K" & @CRLF & _
"(?P<value>.+)"
Local $sString = "Your Balances: <br><br>Points Balance: 600.03<br>" & @CRLF & _
" <br>Last Transaction(s)" & @CRLF & _
" <br>01/11/2019 100050000000 Location1 $14.00" & @CRLF & _
" <br>11/28/2018 100053700000 Location2 $10.50" & @CRLF & _
" <br>10/03/2018 100051800000 Location3 $20.00" & @CRLF & _
" <br>06/26/2018 100047400000 Location4 $17.50" & @CRLF & _
" <br>06/04/2018 100046400000 Location5 $7.00" & @CRLF & _
" <br>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")