$re = '~(?:\G(?!\A)|\QLast Transaction(s)\E\s+)
\s*<br>\K
(?P<value>.+)~mx';
$str = 'Your Balances: <br><br>Points Balance: 600.03<br>
<br>Last Transaction(s)
<br>01/11/2019 100050000000 Location1 $14.00
<br>11/28/2018 100053700000 Location2 $10.50
<br>10/03/2018 100051800000 Location3 $20.00
<br>06/26/2018 100047400000 Location4 $17.50
<br>06/04/2018 100046400000 Location5 $7.00
<br>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);