import Foundation
let pattern = #"""
(?:\G(?!\A)|\QLast Transaction(s)\E\s+)
\s*<br>\K
(?P<value>.+)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
Your Balances: <br><br>Points Balance: 600.03<br>
<br>Last Transaction(s)
<br>01/11/2019 100050000000 Location1 $14.00
<br>11/28/2018 100053700000 Location2 $10.50
<br>10/03/2018 100051800000 Location3 $20.00
<br>06/26/2018 100047400000 Location4 $17.50
<br>06/04/2018 100046400000 Location5 $7.00
<br>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)