use strict;
my $str = 'http://domain.com/too_long_link
http://domain.com/link';
my $regex = qr~((ht|f)tps?://\w[^\s"<,]{0,18})[^\s"<,]*~ip;
my $subst = '<a target="_blank" href="$0" >$1</a>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";