$re = '~((ht|f)tps?://\w[^\s"<,]{0,18})[^\s"<,]*~i';
$str = 'http://domain.com/too_long_link
http://domain.com/link';
$subst = "<a target=\"_blank\" href=\"$0\" >$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;