// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)((ht|f)tps?://\w[^\s"<,]{0,18})[^\s"<,]*"#).unwrap();
let string = "http://domain.com/too_long_link
http://domain.com/link";
let substitution = "<a target=\"_blank\" href=\"$0\" >$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}