using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sudo:\s+(?<field>[^ ]+)";
string input = @"Dec 2 09:02:17 server1 sudo: ib12345 : TTY=pts/0 ; PWD=/home/ib12345 ; USER=root ; COMMAND=/bin/su -";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}