package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)sudo:\s+(?<field>[^ ]+)`)
var str = `Dec 2 09:02:17 server1 sudo: ib12345 : TTY=pts/0 ; PWD=/home/ib12345 ; USER=root ; COMMAND=/bin/su -`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}