re = /sudo:\s+(?<field>[^ ]+)/m
str = 'Dec 2 09:02:17 server1 sudo: ib12345 : TTY=pts/0 ; PWD=/home/ib12345 ; USER=root ; COMMAND=/bin/su -'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end