#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.)"
Local $sString = "Work" & @CRLF & _
"Work" & @CRLF & _
"Fire" & @CRLF & _
"Global{"dmids":[200000298206588]}" & @CRLF & _
"{"dmids":[200000298207769,200000315647883]}" & @CRLF & _
"{"dmids":[200000298207847,200000298559762,200000298729095,200000298937045,200000299376139,200000337459486,200000339993204,2000000298149778]}" & @CRLF & _
"{"dmids":[200000298208329,200000298316016,200000298560524,200000300915842,2000000298179810,2000000298180861]}" & @CRLF & _
"{"dmids":[200000298208335,200000298316025,200000298560517,200000300915858,2000000298179808,2000000298180858]}" & @CRLF & _
"{"dmids":[200000298208343,200000298316014,200000298560521,200000300915848,2000000298179798,2000000298180857]}" & @CRLF & _
"{"dmids":[200000298210597,200000299898455,200000299949910,200000304060818,200000305323250,2000000298190262]}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")