import re
regex = re.compile(r"^(.)", flags=re.MULTILINE)
test_str = ("Work\n"
"Work\n"
"Fire\n"
"Global{\"dmids\":[200000298206588]}\n"
"{\"dmids\":[200000298207769,200000315647883]}\n"
"{\"dmids\":[200000298207847,200000298559762,200000298729095,200000298937045,200000299376139,200000337459486,200000339993204,2000000298149778]}\n"
"{\"dmids\":[200000298208329,200000298316016,200000298560524,200000300915842,2000000298179810,2000000298180861]}\n"
"{\"dmids\":[200000298208335,200000298316025,200000298560517,200000300915858,2000000298179808,2000000298180858]}\n"
"{\"dmids\":[200000298208343,200000298316014,200000298560521,200000300915848,2000000298179798,2000000298180857]}\n"
"{\"dmids\":[200000298210597,200000299898455,200000299949910,200000304060818,200000305323250,2000000298190262]}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")